USDCAD M5 settings

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #4485
    DominikDominik
    Administrator

    In attachment file with my parameters for USDCAD on M5 timeframe.

    Parameters are initially optimized for period of time from 2010 – now.

    I’m waiting for any comments, ideas and opinions how to improve the system and parameters.

    #4655
    DominikDominik
    Administrator

    Hi!

    In attachment you can find new set file for Price Action EA 2.0 which works with USDCAD M5 and is optimized on period 2012-now.

    Graph with auto-lot:

    Graph with fixed lot:

    Report for auto-lot:

    Regards and good luck!

    #4656
    Avataremotuzas
    Spectator

    FANTASTIC USDCAD!

    #4657
    DominikDominik
    Administrator

    @maffel wrote:

    FANTASTIC USDCAD!

    Thanks :)

    Maybe we can make even better set and filter out, among others, this last loss which you can see on graph with auto-lot.

    Regards!

    #4658
    Avataremotuzas
    Spectator

    @Dominik wrote:

    @maffel wrote:

    FANTASTIC USDCAD!

    Thanks :)

    Maybe we can make even better set and filter out, among others, this last loss which you can see on graph with auto-lot.

    Regards!

    in my opinion … it is also normale..and… average DD

    #4659
    AvatarLelik18
    Spectator

    Hi. In USDCAD backtest I get : PRICE_ACTION_EA_2.0 USDCAD,M5: SL_Follow_Points_from_Price (10) is lower than minimum possible (30)! When I change value to 30 the backtest is not good. My broker stop level is zero. What could be the problem?

    #4660
    DominikDominik
    Administrator

    @fusion73 wrote:

    Hi. In USDCAD backtest I get : PRICE_ACTION_EA_2.0 USDCAD,M5: SL_Follow_Points_from_Price (10) is lower than minimum possible (30)! When I change value to 30 the backtest is not good. My broker stop level is zero. What could be the problem?

    Hi!

    The problem is that stop level with your broker for tested currency pair is not 0 – it’s 30, because your account/broker/symbol “says” so :) Expert Advisor takes this number directly from your MT4.

    I made indicator for you. You should put it in “…/MQL4/Indicators/” and open MT4. Add this indicator to the chart with currency pair that you want to test. Open tab “Experts” in “Terminal” window (Ctrl+T) and you will see information about your Account, Symbol and Terminal. Line with “Stop level in points” is your minimum stop level that you can use with your broker on chosen currency. I use broker which has always min. stop level = 0 for each one currency pair. If there is something unclear you can write to me on Skype.

    Regards!

    p.s. If you want to change “SL_Follow_Points_from_Price” to 30 (or few points above 30) you should optimize it together with “SL_Follow_Min_Distance_from_SL” to have reliable results.

    p.s.2. I have one idea. Try to download ticks from Tickstory, but change Stop Level from 30 to 0, as you see on screenshot below:

    #4661
    AvatarLelik18
    Spectator

    Thank you for your help. The problem was that by mistake I was using the old setfile which was on my desktop. When I changed to the new one, problem was fixed. I only get order modify error 130 sometimes but the backtest with 99% quality and fixed spread 20 is attached and is good.

    #4662
    DominikDominik
    Administrator

    @fusion73 wrote:

    Thank you for your help. The problem was that by mistake I was using the old setfile which was on my desktop. When I changed to the new one, problem was fixed. I only get order modify error 130 sometimes but the backtest with 99% quality and fixed spread 20 is attached and is good.

    OK. That’s good. But you shouldn’t have any errors. You can send me on PM/e-mail/Skype screnshot of tab “Journal” with these errors.

    Regards!

    #4663
    AvatarLelik18
    Spectator

    I am unable to upload an image using e-mail or private message so I upload here and you can delete after. I get same problem also for EU.

    #4664
    DominikDominik
    Administrator

    @fusion73 wrote:

    I am unable to upload an image using e-mail or private message so I upload here and you can delete after. I get same problem also for EU.

    That is because of too high Min Stop Level coded in your FXT files downloaded from Tickstory. Open Tickstory, find Button “Metatrader Data Editor” (with pencil) and click on it. Now “Open FXT…”, choose “EURUSD1_0.fxt” and open it. Set “Stop lvl” to 0 and click “Save”. Make the same with file “EURUSD5_0.fxt”. And after that you can test and optimize EURUSD M5 with Stop Level=0. Remember, all your FXT files must have “read only” attributes before you start anything in MT4. If you still don’t know how to do it:

    1. Close MT4.
    2. Delete all FXT files.
    3. Download them once again from Tickstory (remember to set “Stop lvl” to 0).
    4. Don’t open MT4!
    5. Go to location of FXT files and set “read only” attributes to all of them.
    6. Click “Launch” button in Tickstory or press there F8.
    7. If MT4 won’t start just open it manually.

    I don’t know if I can write it simplier that you could understand :)

    #4665
    AvatarTomaszKom
    Spectator

    Hello Dominik,
    are the .set files you provide exactly the same for 4 and 5 digit account ?

    Kind Regards

    #4666
    DominikDominik
    Administrator

    @Carabama wrote:

    Hello Dominik,
    are the .set files you provide exactly the same for 4 and 5 digit account ?

    Kind Regards

    Hi!

    Unfortunately .set files are made for 5 digit accounts. For 4 digit account you must change all parameters which are in points to pips, for example from 20 to 2.

    Regards!

    #4667
    AvatarTomaszKom
    Spectator

    Hi,
    thank you for the answer.
    I am very surprised by your backtests. I have done some and found the Price Action EA to be barely profitable on several consecutive years. I still have to download tick data to be able to run better quality backtests though. By the way why don’t you provide high quality tests instead of n/a quality ? I will post my results here as soon as I have high quality enough tests.

    Kind Regards

    #4668
    DominikDominik
    Administrator

    @Carabama wrote:

    Hi,
    thank you for the answer.
    I am very surprised by your backtests. I have done some and found the Price Action EA to be barely profitable on several consecutive years. I still have to download tick data to be able to run better quality backtests though. By the way why don’t you provide high quality tests instead of n/a quality ? I will post my results here as soon as I have high quality enough tests.

    Kind Regards

    My MT4 shows “n/a”, but real modelling quality is 99,9%. Ticks are downloaded from Dukascopy through Tickstory.

Viewing 15 posts - 1 through 15 (of 20 total)
  • The topic ‘USDCAD M5 settings’ is closed to new replies.